Oui, c'est facile si vous utilisez PMB …

Installation – Réinstallation

 

Quel serveur employer pour quelle version de PMB ?

  • Php 5.2 – MySQL 5.1 pour PMB <= 3.5.1 (ex. EasyPhp 5.2.10)
  • Php 5.3 – MySQL 5.1 pour PMB >= 3.5.1 (ex.EasyPhp 12.1, Wamp 2.2.d ou Xampp 1.7.7)
  • Donc, pour PMB 3.5.1, vous avez le choix entre le Php 5.2 et le Php 5.3
  • Php 5.3 et MySQL 5.1 deviennent obligatoires pour PMB >= 4.0. (C'est indispensable si on veut « profiter » du portail intégré à PMB 4.0)
  • Php 5.4 est possible seulement à partir de la version 4.0.8 de PMB
  • Php 5.4 (ou 5.5 ou 5.6 ) est obligatoire à partir de la version 4.2 de PMB

 

Tutoriels d'installation disponibles sur ce site

 

Installation sous Windows – vue d'ensemble
Comme le sous-titre "vue d'ensemble" le suggère, ce tutoriel vise simplement à dégager les points communs de l'installation, que l'on emploie EasyPhp, Wampserver ou Xampp, il ne contient donc aucune information spécifique à un de ces serveurs.

 

Installation de PMB sous Windows – avec EasyPhp 12.1

Ce serveur est au départ en Php 5.4, mais on peut installer un composant supplémentaire, afin d'y ajouter le Php 5.3.

Ce serveur est vraiment polyvalent et complet

  • Il convient pour Windows Vista, Windows 7 et Windows 8 (je n'ai pas testé personnellement l'installation sur XP)
  • Z39.50 fonctionne directement, yaz est déjà intégré
  • Il gère les versions de PMB à partir de la 3.5.1.
  • Dans sa version Php 5.3, : PMB >= 3.5.1 et <= 4.0.7
  • Dans sa version Php 5.4. : PMB >= 4.0.8

Il permet donc de « profiter » du portail intégré à la version 4.0 de PMB. En effet, la création de ce portail requiert désormais du Php 5.4, 5.5 ou 5.6

 

N.B. Actuellement, sur le site de EasyPhp, on trouve des versions plus récentes, mais le processus d'installation n'a guère changé.

Si vous préférez pouvoir suivre à la lettre ce qui est expliqué dans le tutoriel, je vous conseille de prendre sur Internet la version 12.1 de EasyPhp
http://www.easyphp.org/save-easyphp-latest.php
N.B. Il y a sûrement d'autres sites qui proposent la 12.1 en téléchargement.

 

Installation et paramétrage de l'éditeur html TinyMCE

Pour créer de "belles" infopages dans PMB, il est préférable d’intégrer à PMB un éditeur html visuel, comme TinyMCE. Ce tutoriel vous explique comment l'installer et comment paramétrer PMB.

 

Installation sous Windows – Wamp 2.2.d

Ce serveur (Php 5.3) convient pour XP, Vista et Windows 7 (Z39.50 fonctionne) et pour les versions de PMB >= 3.5.1 et <= PMB 4.0.7

Il ne convient donc plus pour les versions récenges de PMB.

 

Installation sous Windows – EasyPhp 5.2.10

Ce serveur (Php 5.2) convient pour XP, Vista et Windows 7 (Z39.50 fonctionne) et pour les versions de PMB jusqu'à la 3.5.1 y compris.

Il ne convient donc plus pour les versions récenges de PMB.

 

N.B. Dans les tutoriels cités jusqu'à présent, j'explique également comment configurer le serveur Apache et PMB afin de rendre le module de gestion et l’OPAC accessibles via l’Intranet.

 

 


Réinstallation sous Windows – restauration d'une base

On commence d'abord par installer un PMB vide sur un autre ordinateur, ensuite on restaure son ancienne base. J'explique également comment régler le problème des mots de passe, problème inévitable dès qu'on change de version de MySQL.

 

Mise à jour vers une version plus récente de PMB

Que l'on change de serveur ou non, il y a un certain nombre de choses à faire lorsqu'on veut passer à une version supérieure de PMB. Ce tutoriel décrit le processus en détail : mettre à jour les scripts de PMB, adapter la structure de la base de données à cette nouvelle version du programme, réindexer l'index global et tous les champs de recherche, adapter les jeux de sauvegarde.

 

Installation de PMB en ligne

Ce tutoriel contient bien sûr un guide d'installation de PMB en ligne, où les différentes étapes sont décrites pas à pas, mais aussi des réflexions utiles sur le choix de l'hébergement et sur la sécurisation du site et des données vitales de votre bibliothèque.

 

Tutoriels d'installation disponibles sur d'autres sites

 

 

Installation sous Linux – Mandriva 2010 – Régis Viard – Collège Saint-Exupéry

Installation sous Linux – Debian / UbuntuLaurent Plantard

 

Installation sous Windows – Xampp 1.7.1Didier Bellamy (PMB Services)
N.B. Convient pour XP, Vista et Windows 7 (Z39.50 fonctionne)

Attention ! Seulement pour les versions de PMB <= 3.5.1

A partir de PMB 4.0, il faut du Php 5.3 ou 5.4

 

Mise à jour de EasyPhp 1.8 vers EasyPhp 5.2.10 – PMB Services
N.B. Convient pour XP, Vista et Windows 7 (Z39.50 fonctionne)

Attention ! Seulement pour les versions de PMB <= 3.5.1

A partir de PMB 4.0, il faut du Php 5.3 ou 5.4